ПОИСК
Категории книг
ОПРОС
Вопрос: Какой язык программирования вы предпочитаете
С/C++
Delphi
Visual Basic
Perl
Java
PHP
ASP
Другой
ЭТО ПОЛЕЗНО!
ОБРАТНАЯ СВЯЗЬ

/ Главная / Офисные программы / Иллюстрированный самоучитель по Excel 2002
Иллюстрированный самоучитель по Excel 2002

Расчетная область

Перечислим операции, которые выполняет разработанный нами однострочный табель:
- автоматический подсчет количества отработанных часов (столбец АО) с помощью формулы из ячейки АО9:

   =СУММ(Е9:А19)

- определение коэффициента отработанного времени для расчета заработной платы (столбец АР).

В ячейке АР9 производится деление количества отработанных часов на количество рабочих часов, положенных по норме в этом месяце:

   =AO9/$DS5

- автоматическое вычисление количества отработанных дней (столбец AJ) с помощью формулы из ячейки AJ9:

   =СЧЕТЕСЛИ(Е9:AI9;">0")

- автоматическое определение выходных дней (столбец АК) с помощью формулы из ячейки АК9:

   =СЧЕТЕСЛИ(Е9:АI9;"в")

- подсчет больничных дней (столбец AL) с помощью формулы из ячейки AL9:

   =СЧЕТЕСЛИ(Е9:АI9;"б")

- подсчет дней отпуска (столбец AM) с помощью формулы из ячейки АМ9:

   =СЧЕТЕСЛИ(Е9:АI9;"от")

- автоматический контроль правильности заполнения табеля (столбец AN) с помощью формулы из ячейки AN9:

   =ЕСЛИ(СУММ(AJ9:АМ9)=SD$ 6;СУММ(AJ9:АМ9) ;"Ошибка!")

В последней формуле логическая функция ЕСЛИ сравнивает общее количество дней, полученных в области AJ9:AM9, с количеством календарных дней в данном месяце, указанным в ячейке D6. Если условие выполняется, выдается общее количество дней, иначе - текст Ошибка!. Ошибка также может быть связана с некорректным вводом данных (например, вместо числового значения или принятых букв "от", "б" и "в" могут быть введены любые другие символы).

Если работник уволен или принят на работу в текущем месяце

В созданном нами электронном табеле нельзя автоматически определить количество рабочих дней для сотрудников, отработавших неполный месяц по той причине, что они в этом месяце уволены или только приняты на работу. Такую возможность можно обеспечить, модернизировав формулу в ячейке AN9.

В табель следует ввести еще одно текстовое обозначение - "ув". Если количество дней, указанных в области AJ9AM9, и количество дней, которые работник не числился на предприятии, не равны количеству календарных дней, выдается сообщение Ошибка!. После внесения изменений формула в ячейке AN9 примет такой вид:

=ЕСЛИ(СУММ(Аа9:АМ9)+СЧЕТЕСЛИ(Е9:AI9;"ув"}-SDS6;СУММ(AJ9:АМ9);"Ошибка!")

Рис. 7.22. Фрагмент однострочного табеля с формулами для подсчета отработанного времени в часах и днях

Резюме

Автоматизация процесса создания и обработки табелей учета рабочего времени позволяет сэкономить много времени и опять-таки избежать рутинной работы. Как это сделать, рассказано в настоящей главе на примере табелей двух типов: двухстрочного и однострочного. Теперь вы сможете создать табель для своего предприятия, учитывая достоинства, присущие каждому из представленных табелей. Можно также воспользоваться готовым продуктом, который находится на дискете, прилагаемой к этой книге.

Что касается освоения приемов работы с Excel, то здесь в первую очередь следует отметить методику связывания книг и рабочих листов, а также способы их защиты от случайного изменения формул. Создание формул со ссылками на другие листы и книги - это метод, который часто применяется на практике.

Теперь вы знаете, что в Excel существует возможность присваивать ячейкам и диапазонам имена. Если имена отражают назначение данных и формул, находящихся в ячейках, то вам или другому пользователю будет легче разобраться в алгоритме расчета.

Созданная вами таблица будет более удобна в работе, если вы скроете строки и столбцы с промежуточными расчетами.



Компьютерные книги © 2006-2013
computers.plib.ru