ПОИСК
Категории книг
ОПРОС
Вопрос: Какой язык программирования вы предпочитаете
С/C++
Delphi
Visual Basic
Perl
Java
PHP
ASP
Другой
ЭТО ПОЛЕЗНО!
ОБРАТНАЯ СВЯЗЬ

/ Главная / Офисные программы / Иллюстрированный самоучитель по Excel 2002
Иллюстрированный самоучитель по Excel 2002

Сравнение табельных номеров

Теперь давайте проведем сравнение табельных номеров сотрудников в таблицах и тем самым проверим, нет ли здесь расхождений. Для этого применим функцию ЕСЛИ, которая относится к категории Логические (рис. 5.16).

С помощью функции ЕСЛИ можно добиться того, что значение в ячейке будет зависеть от выполнения определенных условий. Синтаксис функции имеет вид:
ЕСЛИ(лог_выражение;значение_если_истина;значение_если_ложь)

здесь лог_выражение (первый аргумент) - это любое значение или выражение, которое при вычислении дает значение ИСТИНА или ЛОЖЬ. Второй аргумент, значение_если_истина, - это значение, которое возвращается, если лог__выраже-ние имеет значение ИСТИНА. Третьим аргументом, значение_если_ложь, является значение, которое возвращается, если лог_выражение имеет значение ЛОЖЬ. Панель функции приведена на рис. 5.17.

Рис. 5.16. Мастер функций, категория Логические

Рис. 5.17. Панель функции ЕСЛИ

Таким образом, функция ЕСЛИ возвращает значение, находящееся во втором аргументе, если условие в первом аргументе дает значение ИСТИНА, и значение, находящееся в третьем аргументе, если заданное условие при вычислении дает значение ЛОЖЬ.

В нашем случае в качестве логического выражения необходимо задать операцию сравнения на равенство табельных номеров из разных таблиц (ячейки D2 и G2). Если они одинаковы, то значением результата сравнения в первом аргументе является ИСТИНА, если нет - ЛОЖЬ.

Чтобы продемонстрировать работу функции ЕСЛИ на практике, выделите диапазон ячеек О2:О11, вызовите панель функции ЕСЛИ и задайте в качестве ее аргументов следующие выражения и числовые значения: D2=G2 (1-й аргумент), 1 (2-й аргумент) и 2 (3-й аргумент).

После нажатия комбинации клавиш [Ctrl+Enter] в ячейке О2 появится следующая формула:

=ЕСЛИ(D2=G2;1;2)

Как выглядит лист Оклады после ввода в диапазон О2:О11 указанной формулы, показано на рис. 5.18.

Обратите внимание на ячейки ОЗ и О10, в которых находится выделенное жирным шрифтом значение 2, а также на строки 3 и 10. Табельные номера в этих строках не совпадают. Поэтому первый аргумент функции ЕСЛИ при сравнении значений возвратил значение ЛОЖЬ, а ему соответствует значение, внесенное в третий аргумент, то есть число 2. Там же, где табельные номера совпадают, функция возвращает значение второго аргумента - число 1.

Рис. 5.18. Результат применения функции ЕСЛИ для проверки соответствия табельных номеров



Компьютерные книги © 2006-2013
computers.plib.ru